Главная Обратная связь Поможем написать вашу работу!

Дисциплины:

Архитектура (936)
Биология (6393)
География (744)
История (25)
Компьютеры (1497)
Кулинария (2184)
Культура (3938)
Литература (5778)
Математика (5918)
Медицина (9278)
Механика (2776)
Образование (13883)
Политика (26404)
Правоведение (321)
Психология (56518)
Религия (1833)
Социология (23400)
Спорт (2350)
Строительство (17942)
Технология (5741)
Транспорт (14634)
Физика (1043)
Философия (440)
Финансы (17336)
Химия (4931)
Экология (6055)
Экономика (9200)
Электроника (7621)






Логическое_значение1, логическое значение2



Рекомендации по выполнению задания_19 ОГЭ

Таблица содержит большое количество записей и требуют навыков работы с большими массивами данных.

Быстрое перемещение по таблице:

Ctrl+Home – в начало;

Ctrl+End – конец;

Shift+F5 – в место последних исправлений.

При решении задачи 19 можно использовать функции (см. Приложение).

Если в условии задачи необходимо найти количество чего-либо, то используем функцию СЧЁТЕСЛИ(диапазон; критерий)

Например,

Светлана Сидорова собиралась полететь на каникулах на отдых и записала расписание перелётов из Москвы в разные города в виде таблицы. Ниже приведены первые пять строк таблицы.

  А B C
Город Страна Примерное время в пути
Абакан РОССИЯ
Абу-Даби ОАЭ
Адлер РОССИЯ
Акаба ЕГИПЕТ

 

Каждая строка таблицы содержит запись об одном маршруте перелёта.

В столбце A записан город назначения, в столбце B – страна назначения; в столбце C – примерное время в пути.

Всего в электронную таблицу были занесены данные по 191 маршруту в алфавитном порядке.

Для какого количества городов расчётное время перелёта составляет более 5 часов? Ответ на этот вопрос запишите в ячейку H2 таблицы.

Курсор – в ячейку H2

=СЧЁТЕСЛИ(С2:С192; ">5")

 

Если в условии задачи необходимо найти процент чего-либо, то используем функции:

СУММЕСЛИ(диапазон, условие, [диапазон_суммирования]),

СЧЁТЕСЛИ(диапазон; критерий),

ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь]) и пр.

Например,

Какой процент от всех 6-часовых перелетов составляют 6-часовые перелёты в города России? Ответ на этот вопрос в виде целого числа нужно записать в ячейку H3 таблицы.

Курсор – в ячейку H3

Подсчитаем все 6-часовые перелеты и запишем в любую ячейку, например, Е2

=СЧЁТЕСЛИ(С2:С192; 6)



Подсчитаем все 6-часовые перелеты в города России:

Для этого в ячейку D2 запишем

=ЕСЛИ(В2="РОССИЯ"; 1; 0)

Скопируем формулу во все ячейки столбца до D192

Посчитаем все 6-часовые перелеты и запишем в любую свободную ячейку, например, Е3

=СУММЕСЛИ(С2:С192; 6; D2:D192)

В ячейку Н3 запишем формулу нахождения процента от всех 6-часовых перелетов составляют 6-часовые перелёты в города России (меньшее число делим на большее! и устанавливаем процентный формат на эту ячейку)

=Е3/Е2

Если в задании необходимо проверить одновременное выполнение двух условий, то можно использовать функции:

ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь])

И(логическое_значение1, [логическое_значение2], ...)

Например,

В электронную таблицу занесли данные о калорийности продуктов. Ниже приведены первые пять строк таблицы.

  А В С D Е
Продукт Жиры, г Белки, г Углеводы, г Калорийность, Ккал
Арахис 45,2 26,3 9,9
Арахис жареный 13,4
Горох отварной 0,8 10,5 20,4
Горошек зелёный 0,2 8,3

Всего в электронную таблицу были занесены данные по 1000 продуктам.



Сколько продуктов в таблице содержат меньше 25 г жиров и меньше 25 г углеводов? Запишите число этих продуктов в ячейку H2 таблицы.

Курсор – в ячейку F2

Проверим выполнение сразу двух условий (для этого: если оба условия выполняются, то в ячейке появится 1, иначе – 0)

=ЕСЛИ(И(В2<25;D2<25);1;0)

В ячейку Н2 запишем функцию, которая просуммирует все полученные 1 =СУММ(F2:F1001)

 

Если в задаче необходимо найти среднее чего-либо, то используем функции:

СУММЕСЛИ(диапазон, условие, [диапазон_суммирования]),

СЧЁТЕСЛИ(диапазон; критерий),

Например,

Какова средняя калорийность продуктов с содержанием белков менее 1 г? Ответ на этот вопрос запишите в ячейку H3 таблицы с точностью не менее двух знаков после запятой.

Посчитаем калорийность при количестве белка<1 и запишем в отдельной ячейке, например J2:

=СЧЁТЕСЛИ(C2:C1001;"<1")

Определим калорийность продуктов с содержанием белков менее 1 г и запишем в отдельной ячейке, например J3:

=СУММЕСЛИ(C2:C1001;"<1";E2:E1001)

Тогда в H3 для определения средней калорийности продуктов с содержанием белков менее 1 г запишем:

=J3/J2

или более подробно:

=СУММЕСЛИ(C2:C1001;"<1";E2:E1001)/СЧЁТЕСЛИ(C2:C1001;"<1")

 

Некоторые функции Exsel

 

ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь])

Функция ЕСЛИ возвращает одно значение, если указанное условие дает в результате значение ИСТИНА, и другое значение, если условие дает в результате значение ЛОЖЬ. Например, формула =ЕСЛИ(A1>10,"Больше 10","10 или меньше") возвращает строку "Больше 10", если значение в ячейке A1 больше 10, и "10 или меньше", если оно меньше или равно 10.

Аргументы функции ЕСЛИ описаны ниже.



Лог_выражение. Обязательный аргумент. Любое значение или выражение, дающее в результате значение ИСТИНА или ЛОЖЬ. Например, "A10=100" — логическое выражение; если значение в ячейке A10 равно 100, это выражение принимает значение ИСТИНА, в противном случае — значение ЛОЖЬ. В этом аргументе может использоваться любой оператор сравнения.

Значение_если_истина Необязательный аргумент. Значение, которое возвращается, если аргумент лог_выражение соответствует значению ИСТИНА. Например, если данный аргумент — строка "В пределах бюджета", а аргумент лог_выражение соответствует значению ИСТИНА, функция ЕСЛИ возвращает текст "В пределах бюджета". Если аргумент лог_выражение соответствует значению ИСТИНА, а аргумент значение_если_истина опущен (т. е. после аргумента лог_выражение есть только запятая), возвращается значение 0. Чтобы отобразить слово ИСТИНА, используйте логическое значение ИСТИНА в качестве этого аргумента.

Значение_если_ложь Необязательный аргумент. Значение, которое возвращается, если аргумент лог_выражение соответствует значению ЛОЖЬ. Например, если данный аргумент — строка "Превышение бюджета", а аргумент лог_выражение соответствует значению ЛОЖЬ, функция ЕСЛИ возвращает текст "Превышение бюджета". Если аргумент лог_выражение соответствует значению ЛОЖЬ, а аргумент значение_если_ложь опущен (т. е. после аргумента значение_если_истина нет запятой), функция ЕСЛИ возвращает логическое значение ЛОЖЬ. Если аргумент лог_выражение соответствует значению ЛОЖЬ, а значение аргумента значение_если_ложь пусто (т. е. после аргумента значение_если_истина стоит только запятая), функция ЕСЛИ возвращает значение 0 (ноль).

 

И(логическое_значение1, [логическое_значение2], ...)

Возвращает значение ИСТИНА, если в результате вычисления всех аргументов получается значение ИСТИНА; возвращает значение ЛОЖЬ, если в результате вычисления хотя бы одного из аргументов получается значение ЛОЖЬ.

Функция И имеет аргументы:

Логическое_значение1. Обязательный аргумент. Первое проверяемое условие, вычисление которого дает значение ИСТИНА или ЛОЖЬ.

Логическое_значение2, ... Необязательный аргумент. Дополнительные проверяемые условия, вычисление которых дает значение ИСТИНА или ЛОЖЬ. Условий может быть не более 255.

 

ИЛИ(логическое_значение1, [логическое_значение2], ...)

Возвращает значение ИСТИНА, если хотя бы один из аргументов имеет значение ИСТИНА или ЛОЖЬ, если все аргументы имеют значение ЛОЖЬ.

Функция ИЛИ имеет аргументы:

Логическое_значение1, логическое значение2...

Аргумент "логическое_значение1" является обязательным, последующие логические значения необязательные. От 1 до 255 проверяемых условий, которые могут иметь значение ИСТИНА или ЛОЖЬ.

 

НЕ(логическое_значение)

Логическое_значение – величина или выражение, которые могут принимать два значения: ИСТИНА или ЛОЖЬ.

Замечания

Если аргумент «логическое_значение» имеет значение ЛОЖЬ, функция НЕ возвращает значение «Да»; если он имеет значение ИСТИНА, функция НЕ возвращает значение «Нет».

 

СРЗНАЧ(число1; [число2]; …)

Возвращает среднее значение (среднее арифметическое) аргументов. Например, если диапазон A1:A20 содержит числа, формула =СРЗНАЧ(A1:A20) возвращает среднее значение этих чисел.

Аргументы функции СРЗНАЧ описаны ниже.

Число1. Обязательный аргумент. Первое число, ссылка на ячейку или диапазон, для которого требуется вычислить среднее значение.

Число2, ... Необязательный аргумент. Дополнительные числа, ссылки на ячейки или диапазоны, для которых требуется вычислить среднее значение. Аргументов может быть не более 255.

 

СЧЁТЕСЛИ(диапазон;критерий)

Функция СЧЁТЕСЛИ подсчитывает количество ячеек в диапазоне, которые соответствуют одному указанному пользователем критерию. Например, можно подсчитать количество всех ячеек, которые начинаются с определенной буквы или содержат числа, большие или меньшие указанного значения. Предположим, например, что есть лист со списком задач в столбце A, а имя пользователя, ответственного за каждую из задач, указано в столбце B. Для подсчета количества повторений имени ответственного в столбце B можно использовать функцию СЧЁТЕСЛИ. Это позволяет определить количество задач, назначенных этому пользователю. Пример:

=СЧЁТЕСЛИ(B2:B25;"Валентин")

Аргументы функции СЧЁТЕСЛИ описаны ниже.

Диапазон. Обязательный аргумент. Одна или несколько ячеек, по которым требуется выполнить подсчет. В этих ячейках могут находиться числа, имена, массивы или ссылки на числа. Пустые ячейки и текстовые значения пропускаются.

Условие. Обязательный аргумент. Число, выражение, ссылка на ячейку или текстовая строка, которая определяет, какие ячейки нужно подсчитать. Например, критерий может быть выражен как 32, ">32", В4, "яблоки" или "32".

 

МАКС(число1;число2; ...)

Число1, число2, ... — от 1 до 30 чисел, среди которых требуется найти наибольшее.

Заметки

Можно задавать аргументы, которые являются числами, пустыми ячейками, логическими значениями или текстовыми представлениями чисел. Аргументы, которые являются значениями ошибки или текстами, не преобразуемыми в числа, вызывают значения ошибок.

Если аргумент является массивом или ссылкой, то в нем учитываются только числа. Пустые ячейки, логические значения или текст в массиве или ссылке игнорируются. Если логические значения или текст не должны игнорироваться, следует использовать функцию МАКС.

Если аргументы не содержат чисел, то функция МАКС возвращает 0 (ноль).

 

МИН(число1;число2; ...)

Число1, число2, ... — от 1 до 30 чисел, среди которых требуется найти наименьшее.

Заметки

Можно задавать аргументы, которые являются числами, пустыми ячейками, логическими значениями или текстовыми представлениями чисел. Аргументы, которые являются значениями ошибки или текстом, не преобразуемым в числа, вызывают значения ошибок.

Если аргумент является массивом или ссылкой, то учитываются только числа. Пустые ячейки, логические значения или текст в массиве или ссылке игнорируются. Если логические значения или текст игнорироваться не должны, следует пользоваться функцией МИН.

Если аргументы не содержат чисел, то функция МИН возвращает 0.

 

СУММ(число1,[число2],...)

Функция СУММ вычисляет сумму всех чисел, указанных в качестве аргументов. Каждый аргумент может быть диапазоном, ссылкой на ячейку, массивом, константой, формулой или результатом другой функции. Например, функция СУММ(A1:A5) вычисляет сумму всех чисел в ячейках от A1 до A5. Другой пример: функция СУММ(A1, A3, A5) вычисляет сумму чисел в ячейках A1, A3 и A5.

Аргументы функции СУММ указаны ниже.

Число1. Обязательный аргумент. Числовой аргумент, который является первым слагаемым.

Число2, ... Необязательный аргумент. От 2 до 255 числовых аргументов, которые являются слагаемыми.

Замечания

Если аргумент является массивом или ссылкой, то учитываются только числа в этом массиве или ссылке. Пустые ячейки, логические значения и текст в массиве или ссылке игнорируются.

Аргументы, которые представляют собой значения ошибок или текст, не преобразуемый в числа, вызывают ошибку Excel.

 

СУММЕСЛИ(диапазон, условие, [диапазон_суммирования])

Функция СУММЕСЛИ используется, если необходимо просуммировать значения диапазона, соответствующие указанному критерию. Предположим, например, что в столбце с числами необходимо просуммировать только значения, превышающие 5. Для этого можно использовать указанную ниже формулу.

=СУММЕСЛИ(B2:B25,">5")

В данном примере на соответствие критерию проверяются суммируемые значения. При необходимости условие можно применить к одному диапазону, а просуммировать соответствующие значения из другого диапазона. Например, формула =СУММЕСЛИ(B2:B5; "Иван"; C2:C5) суммирует только те значения из диапазона C2:C5, для которых соответствующие значения из диапазона B2:B5 равны "Иван".

Аргументы функции СУММЕСЛИ указаны ниже.

Диапазон. Обязательный аргумент. Диапазон ячеек, оцениваемых по критериям. Ячейки в каждом диапазоне должны содержать числа, имена, массивы или ссылки на числа. Пустые ячейки и ячейки, содержащие текстовые значения, пропускаются.

Условие. Обязательный аргумент. Условие в форме числа, выражения, ссылки на ячейку, текста или функции, определяющее, какие ячейки необходимо просуммировать. Например, условие может быть представлено в следующем виде: 32, ">32", B5, "32", "яблоки" или СЕГОДНЯ().

Важно.Все текстовые условия и условия с логическими и математическими знаками необходимо заключать в двойные кавычки ("). Если условием является число, использовать кавычки не требуется.

Диапазон_суммирования. Необязательный аргумент. Ячейки, значения из которых суммируются, если они отличаются от ячеек, указанных в качестве диапазона. Если аргумент диапазон_суммирования опущен, Microsoft Excel суммирует ячейки, указанные в аргументе диапазон (те же ячейки, к которым применяется условие).

 

Примечания

В аргументе условие можно использовать подстановочные знаки: вопросительный знак (?) и звездочку (*). Вопросительный знак соответствует одному любому символу, а звездочка — любой последовательности символов. Если требуется найти непосредственно вопросительный знак (или звездочку), необходимо поставить перед ним знак "тильда" (~).

 


Просмотров 1872

Эта страница нарушает авторские права




allrefrs.ru - 2021 год. Все права принадлежат их авторам!